[Solved] "Error: Invalid Hash" trying to download firmware 1.9.0

Trying to upgrade the firmware and getting:

“Error: Invalid Hash” trying to download firmware 1.9.0


Same thing happening here (UK).

I’m now getting a message after the hash error that I need to update to app version 1.5.3.

Getting the same here
Galaxy S22 Ultra
Currently on v. 1.8

I see they released an update of the app in the AndroidPlay Store, I downloaded it and can get the firmward downloaded now, but when it tries to update I get “cannot connect to adapter” even though I connected to the Carsifi-xxxxxx network with the 1234567890 password.

Aftermarket radio: Alpine ILX-W650
Samsung Note 20 w Android 12
Firmware 1.8

I took the Carsifi into my house and connected it to a powered USB and the firmware upgrade worked.

1 Like

Now it should work. We added a new method to download firmware in 1.5.3, because the previous one wasn’t working well with huge requests.

I tried to update a moment ago. Currently running 1.8.11. I have the latest version of Carsifi from Google Play store. I connect to the car and start the update through the phone, the adapter disconnects from the car and does the whole restart sequence. The phone then says something about “failed to connect to adapter”.

All I can do is hit the update button again in the app, the process then repeats but doesn’t seem to actually load 1.9 onto the adapter?

Do no connect to the car. Take your Carsifi to any USB available (Laptop, desktop). Do the update procedure while not connected to your car.

1 Like

Tried the update with the adapter connected to my PC, still says “Failed to connect” after the update process, if I click on that it says something like “AppException(message: BleTimeoutException; cause:”

Not sure what to do from here, possibly wait for a Play Store App update and hope that clears it up?

Another update, finally got it to work. After attempting multiple times. I connect to a USB that wasn’t my PC (Don’t think this was necessary).

But before hitting the update button, I turned off “Improve first connect”, then I turned “Intercept AA Protocol” back on (My vehicle requires it off). Then the firmware upgrade worked. Turned those options back to their original settings.

Have yet to test it in my car, but at least it seems 1.9 is now loaded on the adapter!