Phone connecting to carsifi at home

The box works just fine in car, shortly after i drive Android Auto pops up on my Kia ev6, but at home in about to throw it in the trash as my Android phone keeps switching to the Carsify network and not my home wify, and so the battle of networks begin. Its so much a pain i rather have cable. Any ideers before i throw it away?

Have you tried “Start/Stop based on car bluetooth name” in the companion app. This stops carsafi connecting to wifi while the car bluetooth is off. This can be found in Star/Stop features, and I beleive you need to select the bluetooth name under the toggle to enable this feature.