MG ZS EV Doesn't work

2019 MG ZS EV :
Samsung Galaxy S10 5g latest firmware
Carsifi delivery firmware version:

Phone BT connects to carsifi, Phone AA connects to carsifi (or says it is in the app) the phone screen flashes and the AA icon on the headunit changes from grey to blue but then back to grey again and nothing else happens. Ive tried intercept AA protocol and changed connection from default to accessory. One option suggested from the help pages that I can’t select it the autofocus one in developer options as this option isn’t present:

I’ve had no help apart from factory reset carsifi, which didn’t work.

Any suggestions?



Hi Matt,

please go thru the tutorials and check if everything set up correctly: Support : Carsifi

This is exactly the kind of generic balls I’ve received already.
You should be able to tell from my initial post that I’ve tried everything in your tutorials. I’ve also sent you the log files. I know another guy with the same car having unresolved problems too.

Give specific help please or accept it doesnt work and issue a refund. I’ll buy a Motorola instead.

Matt Siviter

Have you enabled the wireless projection over the developer settings in AA on your smartphone?
Do you have the chance to try another Android phone?

Yes. I have followed the help files so this setting is enabled. In face I have wasted hours trying all the settings and combinations. I thought this unit was plug and play!

I have a Samsung galaxy s10 5g.Samsung is the second biggest premium phone maker you should be compatible with them.

Hi Matt

We’ve been able to get it working with the ZS EV 2019, and two Samsung phones a Z Flip 3 and S22 Ultra

Like you, I spent some a fair bit of time before stumbling on the support page they had for MG ZS, Skoda and VW which said you had to disable Intercept AA protocol and put the USB connection into Accessory mode. (which you’ve done).

I still got the same thing as you with the momentary Android Auto icon on the headunit going blue for a second and then back to grey again. I went into the car phone settings and unpaired the phones completely. I also went into the Android Auto phone app settings and removed the phones, and then I reset carsifi and tried it all again, with the Intercept AA and it finally worked.

The support page has now been removed/changed to be generic (doesn’t list the MG specifically anymore). Would suggest to Carsifi they list the models back on the support page since it helps with the Google SEO when people are trying to troubleshoot themselves. It also helps explain that whilst most cars are plug and play, a handful are a little bit ‘special’.

That said, once over the quirks it has been working well.
Good luck

Thanks, I’ve tried it all again with the new aa update too. No luck.


Hi Matt, can you share firmware version of your car headunit

Hi, can you share firmware version of your car headunit?

New app version
Firmware 1.9
15 press factory reset after removing all pairings.

Problem still happening.

Adapter not working


Updated everything and used the new remote config as instructed by carsifi customer service but dongle still doesn’t work.

Not working, technical support seems to have given up on the MG ZS EV! And me!

Plug and play my arse!

Just tried with a galaxy s9 too - still doesn’t work. I’d like a refund.

We’ve released v1.9.3 for BETA testers. If you haven’t seen this version in your companion app, please send your UDID to

Did you ever manage to get this working?

As I have an MG ZS EV MK1 which I can’t get working and now have had radio silence from the company since their latest beta version 1.9.5 doesn’t work.

Phones tried are

Google pixel 4 android 12
Google pixel 6 android 13

Latest versions of android auto on both

Hi, please try the latest firmware 1.10.0