Issues with Carsifi Adapter no wifi

Car model(year):
Hyundai Ioniq 2019 & Hyundai Kona 2019

Phone model(Android version):
Samsung Galaxy S10+ (Android v12)

Carsifi adapater firmware version:
V1.8.0 (it says I have the latest firmware)

Issue description:
I am having problems getting AA to work. This has been happening since I unboxed the adapter. I did notice that even when I pair up my phone with the adapter via bluetooth in the official app, my phone never conncts to any wifi. The adapter stays blinking green and I even search for a wifi called “Carsifi_xxxx” but nothing shows up. I even tried using 2.4GHz and played with the other settings I was told toggling might fix. Nothing works. Is the wifi in the adapter faulty?

I was told to factory reset the adapter by pressing the button on the adapter 15 times. Well, it didn’t turn yellow even after 25 times of pressing the button. I did manage to see yellow for like 0.5 seconds when i just click the button MANY times really fast, but it almost immediately goes back to flashing green, which i was told it should take 2 or 3 minutes. So…something must be wrong with my adapter. Any thoughts or help? Am I doing something wrong?

I was hoping to give this to my gf for her birthday next week but with all the delays and now its not working, I’m pretty upset :confused:

I notice people are saying firmware higher than 1.8.0, but I try connecting to the adapter through the app and it says its up to date still. I even tried connecting it to my own home wifi/phone hotspot. Nothing changes. I just get errors like it can’t connect to my wifi or hotspot after idling for 1 minute or so through the app