Carsifi doesn't switch screen after magic button

Lexus es300h 2023
Carsifi-45e55c (v1.10.0)

I’ve just got carsifi and have it working with 2 phones.
When I start the car, it automatically starts, reconnecting the last connected phone.
If I want to change phone with magic button, it disconnects from one and connects to the other, but doesn’t connect to the screen, or at least show AA on screen. When I restart the car, it connects and starts AA on screen with the one I wanted to switch to. It doesn’t matter which phone I’m switching from/to.
Am I doing something wrong?


Hi Ambrose.

To me it does not seem like you are doing anything wrong. I set up the device with two different phones separately. I changed the number of magic buttons clicks required to change phones to only one. Now when two phones are in range and one of them is connected, when I click the magic button the AA screen diseappears from the car’s display, but after 15 seconds AA reconnects for the second phone.

If I remember correctly, in my case it does not always turn the AA homescreen automatically, but this is how it works in my car (2019 Mazda 3) even for one phone. Sometimes when I connect the phone I get to see AA homescreen switching on automatically, but sometimes I still see the car screen with the Android Auto logo appearing on it, and I have to enter the AA manually through my car’s UI.

Either way, after waiting for those ca. 15 seconds I can clearly see that AA is connected again and music starts playing automatically in the background, using the second phone’s Spotify app.

Another press on the magic button and it’s the exact opposite process, with AA screen reconnecting after about 15 seconds to the first phone again and becoming available on the car’s infotainment screen.

If I was you, I would try to set up everything from the beginning:

  • delete both phones from Carsifi through the Carsifi app;
  • delete Carsifi from both phones’ bluetooth paired devices;
  • delete previously connected cars in Android Auto app settings;
  • delete all paired bluetooth devices in the car’s infotainment settings.

Maybe even hard reset the Carsifi itself just to make sure that I’m starting from scratch. Then start the pairing process again. First phone first, then if it’s up and running, switch off the bluetooth and wifi on that phone and repeat the pairing process for the second phone. Then turn the bluetooth and wifi back on for phone 1 and try to switch phones using the magic button (2 clicks by default).

See if it helps.

Thank you, that gives me some hope so I’ll try those steps over the next few days.
Can I ask another question?
When carsifi/AA is connected, if I press the mic to ask Google a question or to make a call, the assistant bar comes up, pulses the logo on the left for a while, and after a long time says something went wrong with the connection. It doesn’t show the transcribed text on the bar.
Also, when connected, I don’t receive texts or WhatsApps.
Are these expected behaviours?

I am not experiencing such issues in my case. My Google assistant works as it should. Are you sure you have granted necessary permitions for the app to use the mic?

For the texts or Whatsapps, I wouldn’t know as I deliberately switched that off.

Maybe someone else can further help you on this, I’m just a regular user like you :).

Does your Google Assist work on your phone when it’s not attached to AA? I had a heck of a time getting my old phone to ‘listen’ to me. I constantly got the ‘something went wrong’ response. I tried and tried and tried to get the Assistant to work but it worked maybe 5% of the time. Then I got a new Moto phone for me so I did a factory reset on my old phone before handing it down to my wife. Only then did Google Assist start working so something was wrong before the factory reset even though every setting was set to allow it to work. A factory reset is an aggressive way to fix such a ‘core’ function but it was the only way for me. I hope you don’t have to resort to it.

Did you work this out? I am having a similar issue. For us, both of our phones connect fine if the other is not in the car, or if the bluetooth of one is off, but pressing the button just disconnects, the AA resets, then reconnects to the same/last phone.