Carsifi 1.7 update not working

Subaru Ascent(2020):
Samsung Galaxy S21Ultra (ver. 12):
**Carsifi adapater firmware version: version1.7

Issue description:

Since the new firmware update. This adapter has not worked for more than 5 mins.

  1. The Display while running maps will freeze, music will still work for a bit. The only way to get it to work is unplug it and plug it back in.
  2. Continually dropping connection and am getting error messages on the screen saying carsifi unit can’t connect.
  3. It will drop connection and than re connect and than disconnect again.

I have fully reset the device and connection between my phone and it still does it. Firmware version 1.6 did it as well but just not as often.

Have you tried switching on only use 2.4ghz wifi? I’ve heard people having connection issues tried that and it worked

1 Like

We need to investigate this issue deeper. Can you please send us an email at Also, will be great if you enable debug mode and collect some logs for us. You can read how to do it here: How report about issue to support team : Carsifi

It was a surprise for us that the 2.4Ghz fixed issue for one of our customers.
But we recommend using 5Ghz WIFI. You can try 2.4Ghz but if the issue still happened you need back to 5Ghz and we will do our best to investigate how to fix it. If 2.4Ghz helps you, please write us here.

Having the same problems myself. Will do the above, but wanted others to know it’s not a one-off issue.

2018 Subaru Outback, stock head unit
Pixel 3, stock Android 12 w/Feb '22 security update
Carsifi 1.7

The common issue here appears to be the Subaru head unit. I have a 2020 Forester that also was having intermittent connection issues. I downloaded the latest firmware (1.8) a few days ago and so far its much better. Still does take about 45 seconds to connect to AA. Phone is Pixel 5A, Android 12, Feb security patch applied.

Please update the firmware to the latest version. 1.7 is outdated