Cadillac cue 3.0 not connecting

Car model(year): 2019 cadillac ct6-v
**Phone model(Android version):**galaxy s22 ultra Android 12
Carsifi adapater firmware version:
Most current
Issue description:
Here are the details:

2019 cadillac ct6-v with cue 3.0 with the most current update.

He samsung galaxy s22 ultra android 12 with current updates.

The unit connects to my phone then the cadillac shows “searching for phone”

Then 1 of 2 things happens.

  1. My phone shows carsifi disconnected, reset your phone communications. Or,

  2. The cadillac stops searching and shows “connect your phone”.

These results are the same using either unit. So far, android auto has not worked wirelessly, only wired. It works fine wired.


I’m having the same issue on my 2020 GMC Sierra.

I am having the same issue with the 2019 Holden Acadia.

1 Like

I am having same issue on Skoda Kodiaq

1 Like

Curious if you were able to get it to work?

I got a 2018 XTS. I had to reset network settings on my phone s21 Ultra. Delete carsifi app. And reset adapter and update from default settings.

Still not working. Still crappy (none) customer support. They were eager to take my money for 2 units that won’t connect

We’ve released v1.9.3 for BETA testers. If you haven’t seen this version in your companion app, please send your UDID to